Xen4.0の導入-問題発生、DomainUのWin7が異常に遅い!

コンピュータ関連のことを、出来る時に、出来ることだけ。
上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。
【Xen4.0の導入】の記事一覧へ




前回のWindows7の問題発生の話です。

■問題発生!
あの後Windows7のインストールは成功し、しばらくは問題なく稼動していました。
ついでに評価版のWindowsServer2008もインストールしましたが問題なし。

ところが、次のステップの準仮想化ドメイン構築でいろいろと試行錯誤している際、ふとWindows7を起動してみると、異常にパフォーマンスが悪くなっていました。起動も遅く(ログオン画面がでるまで10分位?)、マウス動作さえままなりません。Windows7ではリモートデスクトップサービスの設定以外、特に設定変更やアプリインストールなどは行っていないのに、です。

Windows7上でタスクマネージャを見てみると、CPU使用率が常に100%になっている状態でした。
また、WindowsServer2008でも同様の問題が起こりました。


■ざっくり対応
WindowsUpdateにより、自動的に更新されたプログラムが悪影響を及ぼしているのではと思い、Windows7と2008の再インストールを試みましたが、インストール途中で「ドライバが見つからない」とのエラーが出てしまい続行できません。

それでは準仮想化ドメインの構築中にxenに対して問題のある操作をしてしまったのかと思い、ネイティブLinuxのインストールからやり直しましたが、やはりWindows7インストールの段階でドライバが無いと言われてしまい、全く原因不明の状況に。


ググっても全く情報が出てこないので、これは本気で取り組まないとと思った矢先、念のため再度Windows7のインストールを試してみると、問題なくインストールできてしまいました。

まったくもって????な状態です・・・

Windows7起動中
こんな風に、ちゃんと動いてます


■今度起きたら・・・
とりあえず現時点の状態(Windows7インストールに成功した状態)を保存するため、Windows7をインストールしたDomainUのLVをコピー。
# dd if=/dev/VolGroup00/LogVol02 of=/dev/VolGroup00/LogVol03

※LogVol03は、予めLogVol02と同サイズのLVをlvcreateで作成しておいたもの。

その他/etc/xen以下のxen設定ファイルをバックアップ。
# tar -czvf ./xenconf_backup_20100920.tar.gz /etc/xen/



あと、ターミナルソフト(Poderosa使ってます)の設定で自動的にログが取られるようにしました。いままでこのソフトで、自動でログ取る方法調べてなかった(ToT)めんどくさがっちゃダメですね~

次に発生したときは、少なくとも次の4パターンくらいには原因が特定できるようにします。
(1)xen構築時の問題(ビルド時の設定やxend設定ファイルなど)
(2)DomainUの設定ファイルの問題
(3)DomainU内部の問題(Windows7で問題のある設定や操作を行った)
(4)準仮想化ドメイン構築時に何か問題のある操作を行った。


■備忘録
この事象の対処しているうちに、xen関連のコマンドをよく使ったので、忘れないようにメモします。
・xm create -f
 DomainUの起動
・xm list
 起動中のDomainの確認
・xm shutdown
 Domainの停止。IDはxm listで確認
・xm info
 xenの構成情報を表示
・xm top
 各Domainの使用リソースをリアルタイム表示



よくわかんないけど問題は「解消」したので、次に進みます~
決して「解決」はしてないけどね。


スポンサーサイト
この記事へのコメント
URL:
Comment:
Pass:
秘密: 管理者にだけ表示を許可する
 
この記事のトラックバックURL
http://fukushimaya2.blog103.fc2.com/tb.php/7-db5ad9ea
この記事にトラックバックする(FC2ブログユーザー)
この記事へのトラックバック

 | Copyright © ふたごパパのサーバ構築日記 All rights reserved. | 

 / Template by 無料ブログ テンプレート カスタマイズ
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。